video doesn't play on Internet explorer

  • 3
  • Question
  • Updated 6 years ago
  • Answered
My video plays on chrome and firefox but not Internet Explorer iPhone or Android even though I did it in MP4
Photo of VideoManager

VideoManager

  • 1 Post
  • 0 Reply Likes

Posted 7 years ago

  • 3
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1444 Posts
  • 419 Reply Likes
Official Response
To get playback to work across all those browsers and devices, you need more than just the MP4. You also need a player that is able to play the video.

Some browsers support MP4 files through the HTML5 video tag. Other browsers use the Flash Player to decode MP4 files. The iPhone has support for MP4 video, but any interactivity requires an app (yes, we have a free app for this). The iPad is similar, except that in-browser video is allowed, and an app is not required for interactivity. Newer android devices have the same hardware decoding for MP4 video that the iPhone does, and can support MP4 video through HTML5.

The good news is that Camtasia Studio 8 includes a player that does all this for you. We call it the TechSmith Smart Player. It's been developed to enable video playback, plus as many features as the platform or device will allow.

The simplest way to use this player is to use the "Share to Screencast.com" option when you produce from Camtasia Studio 8. This option will produce your video to MP4, and upload the resulting file to Screencast.com, where we host the TechSmith Smart Player. You will get a URL that you use to share your video. You can also use the embed code to embed the video into a page on your own site.

If you wish to host your own video, you can do that too. This is more advanced, but the basic steps are:
1. Produce to a clean folder using Camtasia Studio 8 using one of the presets that includes the video player. Alternatively, you can use Custom settings > Flash > Produce with controller. This gives you the video, plus a set of files that implements the player.
2. Upload all the produced files, including the skins and scripts subfolders, to your web server.
3. Link to the HTML file (not directly to the MP4) from another page. Navigate to the URL of the HTML file in order to view the video.
4. If the video does not play, ensure that the MIME type for MP4 has been set for the web server. Instructions for this can be found here: http://techsmith.custhelp.com/app/ans...

Hope this helps.
Photo of Michel Fortin

Michel Fortin

  • 2 Posts
  • 0 Reply Likes
MP4s are still appearing black (sound only) in IE11, even when produced in Camtasia 8. I tried handbrake to re-encode them in H.264, no success. Help? Videos don't play at all in IE.
Photo of act

act

  • 2 Posts
  • 0 Reply Likes
I have the same problem. Since I'm logged into Windows with a non-admin account (and that is standard at my organization), I don't even get a prompt to enable the ActiveX control. If I elevate my privileges, then it prompts me, and I can play it. Otherwise, black screen in IE11.
Photo of Michel Fortin

Michel Fortin

  • 2 Posts
  • 0 Reply Likes
Apparently, it's a hardware acceleration issue.
Photo of act

act

  • 2 Posts
  • 0 Reply Likes
Good to know. I appreciate the reply.
Photo of Kathi

Kathi

  • 1 Post
  • 0 Reply Likes
What about Camtasia 2 for Mac (version 2.7.0)? The mp4 works on all other platforms, but not Internet Explorer 11. Older videos produced with a different version of Camtasia 2 seem to work fine.
Photo of mlewis222

mlewis222

  • 10 Posts
  • 2 Reply Likes
I am having the same problem as Michael Fortin. I produced a video and all can watch it accept the one running IE 11 - any word on this????
Photo of Luke Stephenson

Luke Stephenson

  • 1 Post
  • 0 Reply Likes
What if the video needs to be hosted externally?  With camtasia 7 the generated html worked fine in IE 11.  Now with camtasia 8 it doesn't.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1444 Posts
  • 419 Reply Likes
From Michel Fortin's comment above, it sounds like an issue with hardware acceleration on some machines.  I'm going to guess that he's referring to the Flash Player trying to use hardware acceleration, which can be disabled from the right-click menu inside of Flash Player.  If that's the case, then the problem is with the Flash Player, or with your video drivers, and not with the MP4.

If you continue to have problems, please contact our TechSupport staff by submitting a ticket at http://support.techsmith.com and someone will follow up with you by email to help troubleshoot further.  If you do find a solution, please consider posting your solution here so that others may benefit. 
Photo of Stormjack

Stormjack

  • 1 Post
  • 1 Reply Like
I recently had a similar problem with a site hosted on a Windows 2003 server.  Firefox and Internet Explorer would not render the videos, but they would successfully launch in Chrome.

Our solution was to adjust the mime-type settings for MP4 video formats in IIS.  On a site-specific level, the mime-type for .mp4 files was set to video/mpeg.  Changing that to video/mp4 solved the problem in our case.

One way to check if this is your problem (without logging into the server) is to visit your video page in Firefox and look at the Warnings tab in the browser Console.  In our case, we had a message 'HTTP "Content-Type" of "video/mpeg" is not supported.'  Then go to the Net tab, the All tab, and then and look at the Response Header for your video.  The "Content-Type" will show up there.

Here are a few related links if you suspect this is your situation:
http://bit.ly/R7J22e
http://bit.ly/1ksNVMc
http://mzl.la/PU4A1v

Apparently those browsers are more exacting (or less forgiving) when it comes to rendering videos according to the named mime-type.

This conversation is no longer open for comments or replies.