Videos uploaded to Azure Media Services are not streaming in Chrome

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I'm having a problem loading videos that I've created in Camtasia up to  Azure Media Services.  The video will stream in IE and Firefox, but they only download to the desktop in Chrome and Safari.  To test again, I loaded one of your tutorials (cs8-tutorial-quizzing-sample-quiz) and it ran properly.

I've been saving as 720 p, .mp4 only.

I have 2 questions:
  1) has anyone else seen this?
  2) How are the tutorial videos rendered?  I may try to duplicate the rendered settings and see if that helps.

Sure would love to understand what the deal is.
Photo of Scott Roper

Scott Roper

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Josh Holnagel

Josh Holnagel, Employee

  • 427 Posts
  • 80 Reply Likes
Hi Scott,

I don't have much experience with Azure Media Services, but I can tell you our tutorials are custom .mp4 productions. We produce them with the player to get the XML file needed for hotspots and , in this case, quizzes. Older videos will have dimensions of 800 x 450, and newer ones will be 854 x 480.

I'm sure you noticed this, but the quizzing sample is a very short video, in addition to being a smaller size. So some factors that might be in play are:
  • Video length
  • Video file size
  • Video dimensions
Maybe it's a browser setting that is telling Safari and Chrome to download larger/longer/taller files instead of streaming them? I did a quick search on the Azure forums, but couldn't find anything. You may try contacting their support as well. 

-Josh
(Edited)
Photo of Scott Roper

Scott Roper

  • 3 Posts
  • 0 Reply Likes
Hi Josh,

After trying just about everything, we finally found the problem was that file names uploaded to Azure Media Services will not stream in Chrome if there are spaces in the file name.  They will stream in IE and Firefox.

Thanks for the reply
Photo of Josh Holnagel

Josh Holnagel, Employee

  • 427 Posts
  • 80 Reply Likes
That's very interesting. Thanks for posting your findings here. Other people may come and find this solution. Glad you were able to figure it out. 

This conversation is no longer open for comments or replies.