Webcam is not working in Snagit 2019

  • 2
  • Question
  • Updated 12 months ago
Webcam is not working in Snagit 2019 in windows 10 laptop.

error I am getting-  web camera is not connected. attach a webcam to your computer or change the privacy setting to allow the snagit to access the webcamera.

already tried the below KB, but still no luck.
https://support.techsmith.com/hc/en-us/articles/360004018172-Snagit-Windows-Camera-Microphone-Not-Working-on-Windows-10
Photo of tarungupta0311

tarungupta0311

  • 3 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Paul Turley

Paul Turley

  • 9 Posts
  • 7 Reply Likes
I upgraded to an HD webcam and began having similar problems. Because the high resolution camera requires more power, I have to connect it directly to my laptop rather than the USB hub. Had nothing to do with Camtasia.
Photo of Rick Stone

Rick Stone

  • 6620 Posts
  • 3181 Reply Likes
I had a similar issue with a condenser USB mic. Perhaps you might consider a powered USB hub? That solved it for me.
Photo of Paul Turley

Paul Turley

  • 9 Posts
  • 7 Reply Likes
Thanks. It is powered but can't carry the power and signal as effectively as three machine itself. BTW, I meant that the problem was not with SnagIt (nor Camtasia). It was hardware related.
Photo of tarungupta0311

tarungupta0311

  • 3 Posts
  • 0 Reply Likes
I doubt its a hardware related, all other applications are able to use webcam like, Skype, Camera, Facebook.
and its Laptop, we can't provide extra power to webcam.

All drivers are already updated.
Even I reinstalled the application.
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
What webcam are you using with your system in Camtasia and SnagIt ? Just curious to know and check it out as I have a few webcams that are HD and have had no issues knock on wood.

Regards,

Fred
Photo of tarungupta0311

tarungupta0311

  • 3 Posts
  • 0 Reply Likes
Its inBuilt webcam from SunplusIT.
I am pretty sure its some setting, might be in registry which we may have to edit to fix this.