What can I do to stop the wavy lines in my produced video?

  • 1
  • Question
  • Updated 10 months ago
I have a camera that produces video in .MTS. I use Handbrake to convert batches into .MP4 so I can import them into Camtasia. 

If I watch the MP4's they look great and don't have any problems. 
When I import them and watch the video, anytime someone moves real fast I get a weird wavy line effect. 

Is there anything I can do to fix this? 
(see attached .gif)
Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes

Posted 10 months ago

  • 1
Photo of Michael

Michael

  • 42 Posts
  • 10 Reply Likes
It looks like the video you created is interlaced. I don't know Handbrake, but is there a way you can deinterlace the .mts files as you convert them to .mp4?
Photo of Joe Morgan

Joe Morgan

  • 5652 Posts
  • 2929 Reply Likes
I agree with Michael your video looks like it was shoot in interlaced mode. That mode is usually reserved for and shooting 60fps and higher frame rate footage

Shoot your videos at 30fps and 1080P or 720P ,etc.. Not 1080i or 720i etc.

Camtasia's timeline only supports 30 fps footage. Importing higher frame rate footage only bogs down the editor and creates unneeded problems.

Regards,Joe
Photo of Lawrence Milligan

Lawrence Milligan

  • 4 Posts
  • 0 Reply Likes
Yep, it's interlaced - change it to 30 fps progressive.
Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
So after doing a bit of research, someone mentioned that you can upload your clips to youtube, download the converted product and import into camtasia. 

This actually works. 
WHY? 

I put the files side by side and it looks like it's a size issue to me?!?!? 



Does anyone have an explanation on what the best settings should be? 
Photo of Rick Stone

Rick Stone

  • 4353 Posts
  • 1929 Reply Likes
Sorry, but I have no explanation on the settings issue. But on the "WHY" issue, it's because YouTube takes the uploaded video and transcodes it to two or more separate files. So something about the transcoding process being used by YouTube is affecting things.

As for a really deep technical explanation, you likely need a YouTube engineer to properly explain it.

Cheers... Rick :)
Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
Here are my handbrake settings

Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
I've done over 10 separate tests here and it absolutely is starting to look like a file size issue. 
There are different presets in Handbrake that I've been looking at and there is a universal one that seems to work. 

I tried to mirror those settings while still using the 1900x1080 file size and continued to get the problem. 

So it seems like the only thing I can do to stop it is choose a 720 (width). 
Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
UGK! 
Placing a 720 compressed video on top of a high-rez blurred image makes my content look like a cartoon! 
This is very unsettling .
Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
Ultimate fix, Changed the output of the camera to .MP4