When using Erase and Fill, an edge will stay around the filled object

  • 1
  • Question
  • Updated 10 months ago
This didn't happen in Snagit 12 but since 13 and now 2018, whenever I erase an area and then fill it with a color, an edge will stay around the filled area, which won't adapt the color. I then have to manually fill each pixel.
I am sure there is something easy that I am missing.
Can you help?
Photo of jzurner

jzurner

  • 2 Posts
  • 1 Reply Like

Posted 10 months ago

  • 1
Photo of Rick Stone

Rick Stone

  • 4484 Posts
  • 1999 Reply Likes
When you fill, have you tried increasing the tolerance before filling?
Photo of David Howell

David Howell, Employee

  • 97 Posts
  • 31 Reply Likes
I agree with Rick here.

If you leave the "Antialias" setting on, the edges of the erased area are blended with the canvas color in order to smooth the result. When you use the fill tool in that area with a low tolerance, it won't fill some of those edge pixels since the color does not match exactly.

To better address this, you can try:
(a) Turning off Antialias on the erase tool (the results will be more "jagged", but the fill in that area will get everything)
(b) Increase the tolerance, as was suggested. This will fill more of those blended colors along the edge (making it as jagged as just turning off anti-alias in the first place).

HTH!
Photo of jzurner

jzurner

  • 2 Posts
  • 1 Reply Like
Turning up tolerance worked.
I had ti turn it up to 95% for the edges to get filled as well.

Thanks.
Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
95% Tolerance on any of my projects would fill in the whole area!
I think I max out usually at 45%