Why does my mouse pointer not show in screen recordings?

  • 1
  • Question
  • Updated 4 months ago
Why when I record my screen does the mouse pointer/cursor not appear in the recorded video? I'm using Camtasia version 2018.0.1 (build 3457). Obviously with the pointer not present camtasia won't allow me to utilise the cursor effects which I require.
Photo of Rob

Rob

  • 4 Posts
  • 1 Reply Like
  • frustrated

Posted 9 months ago

  • 1
Photo of Rick Stone

Rick Stone

  • 5908 Posts
  • 2820 Reply Likes
Hi there

I'm not sure why it happens. But it happened to me a ways back. TechSmith support had me change the recording type from TREC to AVI in the Recorder settings. From the Recorder, click Tools > Options.



This fixed it for me. But the down side is that when you make this change, the mouse effects in Camtasia are no longer possible because this setting causes the mouse to become "burned in".

Hopefully this will be helpful to you.

Cheers... Rick :)
Photo of Rob

Rob

  • 4 Posts
  • 1 Reply Like
Hi Rick

Changing it to avi does work with showing the pointer but it still won't allow me to add any cursor effects to my screen recording. One issue down, one to go :)

Thanks

Rob
Photo of kayakman

kayakman, Champion

  • 7216 Posts
  • 2409 Reply Likes
suggest you contact free tech support re this issue
Photo of Jayne Davids

Jayne Davids

  • 203 Posts
  • 180 Reply Likes
Hi Rob,

When you select the .trec on the timeline, do you have cursor properties in the properties panel? Just wondering if the opacity has been set to 0%

Cheers,

Jayne @Raiveon
Photo of Rob

Rob

  • 4 Posts
  • 1 Reply Like

Hi Jayne,


Cursor properties doesn't appear in my properties panel. I only have video and sound properties to play with.

Thanks for taking the time to reply

Rob
Photo of Dubie

Dubie

  • 1511 Posts
  • 1246 Reply Likes
Unless there is a reason you haven't, I would update Camtasia to the latest version which is 2018.0.7

You may possibly just have a corrupt or missing file or not knowing your operating system, a OS update may have changed things.

You can update from within Camtasia or get the latest version here
https://www.techsmith.com/download/oldversions

Check that your drivers are up to date also.

Shy of that support would be your next best stop.


Dubie
TechSmith Resources         
Support      Tutorials     Version Downloads _________________________________________________________

(Edited)
Photo of Rob

Rob

  • 4 Posts
  • 1 Reply Like

Thanks Dubie, I have contacted tech support and they suggested the same thing. I'm downloading the update now. Hopefully this will fix my issue.

Thanks

Rob
Photo of Dubie

Dubie

  • 1508 Posts
  • 1240 Reply Likes
Hope that fixes it for you. Fingers crossed.

If you get a chance let us know if it worked.



Dubie
TechSmith Resources         
Support      Tutorials     Version Downloads _________________________________________________________

Photo of celliott

celliott

  • 3 Posts
  • 3 Reply Likes
This is still a problem. I'm up to date and having the invisible cursor problem too. I never had the problem until I discovered I should be using the "Pause" button when recording, which I loved up until it started causing the cursor to disappear  periodically during the same .trec recording. I'm not a fan of the .avi solution because that's just a flattened movie format and I use the cursor editing features, like turning it off sometimes. Rendering the movie doesn't bring it back. I can apply cursor filters because they think it's there, I get the cursor properties, but those don't do anything.

If any of that helps, perhaps this can be fixed. It happens maybe once every 10 pauses, very intermittent. My only advice is, stop using the pause button, unfortunately.
Photo of Joe Morgan

Joe Morgan

  • 6828 Posts
  • 3759 Reply Likes
What operating system are you using?
I'm asking because this was a problem that seemed to afflict Windows 7 users primarily and possibly Win 8 users as well.
There were a lot of posts regarding this behaviour with Camtasia 8. Before Windows 10 was released.
It's rare to see this reported these days. I'm just trying to rule out the operating system as the source.

Regards,Joe