Why does snagit open every time I save a jpg file?

  • 1
  • Question
  • Updated 4 years ago
There must have been a recent setting change that I didn't account for.  Every time I save a .jpg file from the web, instead of just saving it to my hard drive, SnagIt opens as well.  I might occasionally want to edit a photo, but right now I'm trying to capture a number of images, and just save them.  Any suggestions on how I can turn off this setting?
Photo of Craig Backus

Craig Backus

  • 3 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Rick Stone

Rick Stone

  • 5953 Posts
  • 2838 Reply Likes
Hi there

Unfortunately I don't have an answer for you but I do have some questions that I might imagine others would need the answers to before they could help.

For example:
What browser are you using? (don't forget the version)
What version of SnagIt?
Exactly how are you trying to save the image? (please be specific in listing the steps)
Is it only JPG images or does it also happen with other image types too? (PNG, BMP, GIF, etc)
What is your operating system? (Windows 7, Windows XP, Windows 10, Apple, etc)

Cheers... Rick :)
Photo of Joe Morgan

Joe Morgan

  • 7602 Posts
  • 4152 Reply Likes

It sounds like one of your profile settings got changed somehow.

Correcting this depends on which version of SnagIt you use. For SnagIt 12 you need to capture using a custom profile. The Big Red Button cannot be controlled or altered.

You would make similar setting changes as suggested in the image below. The Image is SnagIt 11. Click the image to enlarge.

 For this version you need to disable "Preview in Editor"' for the profile you are using. You also need to have a folder or location for the jpeg to be saved to. If not, you cannot disable the Preview in Editor feature.

 Regards, Joe

 
(Edited)
Photo of Craig Backus

Craig Backus

  • 3 Posts
  • 1 Reply Like
I'm using Google Chrome, Version 45.0.2454.101 m

SnagIt, Version 12.4.1 (build 3036)

Windows 10

Saving pictures by right-clicking on the image, and then choosing "Save Picture As"  This brings up the Windows explorer, allows me to choose a directory, and then SnagIt launches automatically.  It happens for every .jpg, and I just tried a .png, and it did not happen.

I saw Joe's recommendation about diabling "Preview in Editor" but I'm not sure where to find that.
Photo of Joe Morgan

Joe Morgan

  • 7602 Posts
  • 4152 Reply Likes
The Big Red Button will not work for the captures you want to perform. You need to change the  custom profile for image capture to do this. "Step 2". You could also create a custom profile from scratch, but that requires additional steps.
You will need to use a Hot Key for all of your captures. You will also need to save your captures to a specific location. Take your pick from the drop down menu at step 4. The example shows you how to set up a folder for your captures.
See Image Below.

Let me know if this works or if you need anything else.

Regards, Joe

(Edited)
Photo of Rick Stone

Rick Stone

  • 5953 Posts
  • 2838 Reply Likes
Personally, I'd be surprised to discover there is anything in SnagIt settings that would change this behavior. I'd be more inclined to think it's stemming from something in Windows 10. And my gut is saying it's likely got something to do with file association.

But that's just me. ;)
Photo of Rick Stone

Rick Stone

  • 5953 Posts
  • 2838 Reply Likes
Perhaps give the link below a look and maybe try what is outlined there?

Click here to view

Cheers... Rick :)
Photo of Rick Stone

Rick Stone

  • 5953 Posts
  • 2838 Reply Likes
I found another page that may help as well. This one is Chrome specific. Sounds to me as if you have the setting enabled to open the JPG file type when finished.

Click here to view

Cheers... Rick :)
Photo of Craig Backus

Craig Backus

  • 3 Posts
  • 1 Reply Like
That helped me get to the answer....  I evidently hit "Always open files of this type" in Chrome by accident when I opened a .jpg file recently.  I had to go into settings in Chrome, and then I did a search for "auto-open."  This brought me to the settings for Downloads, and there was a button that says, "Clear setting to Always open files of a certain type."  Once I pressed this button, I'm able to right click on the picture, and choose where to save it, and it doesn't automatically open SnagIt.  

Thanks for the guidance!

This conversation is no longer open for comments or replies.