Why Snagit 2018.2 always light up my webcam?

  • 6
  • Question
  • Updated 4 months ago
Snagit was fine since I started using it last year until today I upgraded it to version 2018.2. It always light up my webcam when starts. I have already disabled my webcam in preferences and even switched off mic recording. Any hidden place to search to stop Snagit using webcam? My webcam is Microsoft Lifecam Studio. Each time it is used, a blue LED on it lights.
Photo of olive

olive

  • 5 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 6
Photo of olive

olive

  • 5 Posts
  • 0 Reply Likes
Add: I tried to disable the mic of webcam and then the light went off. So the light actually indicates the use of mic on webcam, in this case. But I have already switched off mic, and selected another mic on my PC. It still lights. Unlike webcam, I find no way to disable mic in Snagit.

Is there a better solution? It should go off if I switch off mic or select another mic!
Photo of Dubie

Dubie

  • 924 Posts
  • 701 Reply Likes
Check if you have the web cam option Un-checked in the capture preferences.
That might be it.

:)
Photo of Joe Morgan

Joe Morgan

  • 5538 Posts
  • 2876 Reply Likes
I just tested my Logitech webcam.
If it's disabled it doesn't light up.  "In Preferences"
I'm running 2018.2.0

You  should probably contact tech support.It sounds like a bug to me.

This is a Free Service............... Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

(Edited)
Photo of olive

olive

  • 5 Posts
  • 0 Reply Likes

@Dubie I have already disabled webcam there.

@Joe Does your Logitech webcam have a mic? As I mentioned in my post, it's not the cam, but the mic -- even though I switched off the mic, or select another mic, it always lights up, until I disabled the mic in Windows. So it's the mic that lights up the cam.

Photo of Joe Morgan

Joe Morgan

  • 5538 Posts
  • 2876 Reply Likes
Yes it has , and sure enough. It was disabled as I use a Headset mic.
So I enabled it. And like you, my webcam lights up now. I don't use SnagIt to record video, I use Camtasia.Camtasia doesn't have the same issue I'm happy to report.
Photo of olive

olive

  • 5 Posts
  • 0 Reply Likes
Thank you for the test. So mine is not a specific case,
Photo of racoutu

racoutu

  • 3 Posts
  • 1 Reply Like
Did not work for me, the only way on mine is to close one-click
Photo of olive

olive

  • 5 Posts
  • 0 Reply Likes
Don't understand your response?
Photo of Perry

Perry

  • 14 Posts
  • 5 Reply Likes
I'm having the same problem. I have disabled the webcam option but the blue light comes on as soon as Snagit opens. It's only happened with the lastest version, so as far as I'm concerned it's a bug or an unwelcome feature.
Photo of jmalarcon

jmalarcon

  • 1 Post
  • 0 Reply Likes
Same thing happening here. Microsoft LiveCam HD-3000 and Snagit: blue led always on. It's because of the integrated mic in the camera. This is a very annoying bug in the latest Snagit version and I hope Techsmith will fix it very soon :-(
(Edited)
Photo of Perry

Perry

  • 14 Posts
  • 5 Reply Likes
I have the LiveCam too. I turned off the mic, but still it happens. Very irritating.
Photo of kbrant

kbrant

  • 3 Posts
  • 0 Reply Likes
Same issue here. Having a a Trust WB-6250X Wecam. Disabled webcam in prefferences and select another mic than the webcam mic. Still the light comes on. I shutdown snagit because it feels as if somebody is spying on me. That means of course no quick screenshot :-( I hope this can be fixed quickly! It happened in the last update, the previous version of 2018 was fine.
(Edited)
Photo of s.o.

s.o.

  • 1 Post
  • 0 Reply Likes
Hi there, I'm having the same issue. Since installing the new version, the webcam/integrated microphone is always activated.
Photo of Rob Sinclair

Rob Sinclair

  • 1 Post
  • 0 Reply Likes
I'm having the same issue with my Microsoft LifeCam Cinema. I need to close the one click to get it to deactivate.
Photo of Perry

Perry

  • 14 Posts
  • 5 Reply Likes
Photo of kbrant

kbrant

  • 3 Posts
  • 0 Reply Likes
Hey Perry, That didn't fix the problem. Verified the registry to make sure it was patched and restarted PC.  Same result, light comes on...
Photo of Joe Morgan

Joe Morgan

  • 5538 Posts
  • 2876 Reply Likes

I suggest you reinstall SnagIt 2018.1.1 until they straighten out this mess.

 Just make sure when you uninstall Version 2.0 you save your files.

 I see TechSmith has removed version 2018.1.1 Build 924 from the previous download page already.

I don't know why they keep doing this with so many versions. You should be able to find the version in your downloads.Just check it's properties and details because there will probably be multiple files all named the same.snagit (X).exe


 I've gotten used to TechSmith limiting access to previous versions.So I archive versions. If you need 18.1.1 I'll upload it for you.

 Regards, Joe

(Edited)
Photo of Perry

Perry

  • 14 Posts
  • 5 Reply Likes
kbrant, it worked for me. Did you check the settings to ensure the webcam was set to off? Still, I think Joe's suggestion is the better one.
Photo of kbrant

kbrant

  • 3 Posts
  • 0 Reply Likes
Did Joe's advise and I'm back to 18.1.0.775 (that's the version I still kept). Problem fixed (for now). I'll keep an eye on this post to see if somebody can confirm it is permanently fixed.
Photo of d

d

  • 1 Post
  • 0 Reply Likes
Same problem. Last Snagit, Windows 10, Microsoft HD WebCam