Why can't I play video in Snagit editor?

  • 6
  • Question
  • Updated 5 years ago
Once I upgraded to Snagit 11.x, I can't seem to play a video from the editor. I see the videos there and they are shown as a video with the duration. How can I play?

If I have an mp4 file on my disk somewhere, I can double-click it and play it without any trouble.
Photo of amil

amil

  • 15 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 6
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey Amil,

What OS are you using? And what version of Snagit exactly? Thanks!
Photo of amil

amil

  • 15 Posts
  • 0 Reply Likes
Snagit 11.2.0, build 101.
Windows Server 2008 R2, SP1
Photo of Mary Cooch

Mary Cooch

  • 4 Posts
  • 3 Reply Likes
I have just bought and downloaded the latest version of Snagit today on a brand new Windows 8 laptop and I can no longer play the videos either. I am used to older versions of Snagit where the video (or image) appears in the editor as soon as you have taken it. But even if I click on the video it won't come up in the editor for me to play it. (If I click on an image, that does appear in the editor)
Photo of Timmysf

Timmysf

  • 1 Post
  • 0 Reply Likes
I purchased a laptop that came with Windows 8 and haven't been able to get video to play back in Snagit Editor. I uninstalled Snagit and reinstalled. Still not working. I downloaded and installed 11.2 a few minutes ago and after restarting the laptop, still can't get the video to play back in Editor. I've never had this issue on my desktop computer and can playback videos in Editor. Is there an issue with Windows 8 and Snagit or am I overlooking a setting or something very easy to fix this?

This reply was created from a merged topic originally titled
Can't play back video in Snagit with Windows 8.
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey everyone,

First thing, is make sure your audio drivers are updated to their most recent versions.

Let me know if that does anything for you! Thanks!
Photo of amil

amil

  • 15 Posts
  • 0 Reply Likes
Yep...things all appear updated.
Photo of amil

amil

  • 15 Posts
  • 0 Reply Likes
So...still no luck on this one. Could it be Server 2008 R2?
Photo of Mary Cooch

Mary Cooch

  • 4 Posts
  • 3 Reply Likes
I confess I uninstalled Snagit 11 on my brand new laptop and I installed Snagit 10 and I am fine with that - in additon to being able to play the videos it also lets me save as avi which is very important to me in my work.
Photo of amil

amil

  • 15 Posts
  • 0 Reply Likes
Snagit folks...so...do I assume that your recommendation to the community is to uninstall your latest version and start using older version(s)?
Photo of Manny Carvalho

Manny Carvalho, Champion

  • 1175 Posts
  • 192 Reply Likes
If using AVI is important to you than that's your only solution at the moment. Although, personally, I doubt that Snagit will go back to that filetype. It had too many limitations and Snagit isn't TechSmith's video handling program.
Photo of Nil

Nil

  • 1 Post
  • 0 Reply Likes
IJust purchased Snagit 11 and I use windows vista 64-bit. I cat see video on snagit editor I keep getting message not support with video dimension 1920x 1080
Photo of graememcinnis001

graememcinnis001

  • 1 Post
  • 1 Reply Like
my videos wont play in snag-it editor. I can see them there...but they just dont play. They did when i first got it, only a few days ago...now nothing. I have windows 7 sp1 64 bit. Why dont you guys have a tech line? 
Photo of Violet Weed

Violet Weed

  • 8 Posts
  • 1 Reply Like
I had problem this morning 3/26/2014 w mp4 vids not playing in SnagIt11 11.4.2 (build 263). Machine is win7x. A warm reboot (restart only, not shutdown/reboot) fixed the problem. I wonder if there is a memory leak issue, but I ask that naively.

Photo of Tridy

Tridy

  • 3 Posts
  • 2 Reply Likes
It is the same problem with no video editing/trimming (preview/editing of the images works alright) in Snagit 12.0.0.1001 on Windows Server 2008 R2 Standard (Citrix virtual machine). Restart does not help.



=== Snagit 12.0.0.1001 [enu] Diagnostics ===

System Information:
Windows 6.1 Build 7601 Service Pack 1
Display Width: 3840
Display Height: 1200
Display Origin: 0,0
Display Colors: 32 bit

Updater Information:
Product name: Snagit, 32-bit
Current version: 12.0.0, next version:
Bitness: 32
Language: ENU
Key type: Single User, version: 0
Software key: [REMOVED]
Next run: 5/27/2014 12:00:00 AM
Current status: CheckingFailed
Message: The remote server returned an error: (407) Proxy Authentication Required.
Retry count: 0





Photo of Ian Jackson

Ian Jackson

  • 1 Post
  • 0 Reply Likes
Tried 11 and 12 both have same issue.  Laptop has Win7.  Is there any idea when TechSmith will fix this?  We buy lots of SnagIt licences every month but until it's fixed, I have to recommend not buying any more.  Can anyone suggest an alternative piece of software that does work...

(Edited)
Photo of 1nd1g0

1nd1g0

  • 1 Post
  • 0 Reply Likes
What an absolute disgrace!
Both Snagit 11 & 12 fail to handle any kind of video, always complaining that it is too large (greater than 1920 x 1080) when it is plainly not so!
Is there no hope for Snagit Video?

Luckily, all is not lost!

The solution is to go to %LOCALAPPDATA%\TechSmith\Snagit\DataStore
and there you will find your Video as an MP4 file. Just click on it and you will see it in your default Video Player!

(Edited)
Photo of Sam Lowe

Sam Lowe

  • 2 Posts
  • 0 Reply Likes
Just wanted to make sure that a customer should be able to use Snagit's video playback/editor independent of Camtasia. Right?
Photo of amil

amil

  • 15 Posts
  • 0 Reply Likes
I can't recall, but somehow this was fixed and I am able to play the video now.  Using the latest version of snagit v12.
Photo of Lane Jung

Lane Jung

  • 1 Post
  • 0 Reply Likes
Well, as this still seems to be an issue, consider yourself with one less customer.
Going back to Adobe.

This conversation is no longer open for comments or replies.