SnagIt is capturing incorrectly ("blotchy bits")

  • 1
  • Problem
  • Updated 9 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposting

I'm using SnagIt 10.0.0 build 788 on Windows 7 Ultimate 64 bit. I've noticed that the last couple of days when I capture something, a highlighted button doesn't get captured properly and is missing blotchy bits. Sometimes if I simply re-capture the second attempt looks proper. And sometimes it takes me three tries to get it captured.
Photo of Rick Stone

Rick Stone

  • 5620 Posts
  • 2667 Reply Likes
  • frustrated

Posted 9 years ago

  • 1
Photo of Rick Stone

Rick Stone

  • 5620 Posts
  • 2667 Reply Likes
Here is a sample of the image.
Photo of Matt Dyer

Matt Dyer

  • 13 Posts
  • 1 Reply Like
Official Response
Rick-- What you're seeing is a combination of Snagit's window capture attempting to grab transparency information and Windows 7 animating the OK button.

Whenever you mouse-over a button, there's a subtle animation Windows does. If you start a capture with Snagit while that animation is still playing, Snagit takes its screenshot in the middle, and as a result it can miss a few pixels while it's figuring out what is and what isn't transparent in that window.

There are three ways to avoid this problem:

1) Before starting a capture, let your window "settle" for a few seconds. This usually just means not moving your mouse in the few seconds before you hit your capture hotkey. This is what you're doing when you get a "good" screenshot.

2) Select a region instead of using the window selection tool. Snagit only attempts to capture transparency information when you select a window to capture.

3) You can turn off the transparent window capture in the input properties (the last option on the input dropdown menu). There are three options here. Changing the option to "actual title bar" disables any attempt to capture transparency and should eliminate weird artifacting.

The first solution should solve this most (if not all) of the time.
Photo of Rick Stone

Rick Stone

  • 5620 Posts
  • 2667 Reply Likes
Thanks so much for the info! I will have to look at the profile settings.

For what it's worth, I Love Love Love the new "All in one" profile that was added to SnagIt 10. Unfortunately, it fails me in some cases and forces me to switch to a different profile in order to capture. For example, if I right-click and present the context menu and attempt with All in one, Upon selecting what I want, the context menu is dismissed and all I get captured is the screen before I summoned the context menu.

Sooo, if you are looking for a way to improve it... ;)

Thanks again... Rick :)
Photo of Rick Stone

Rick Stone

  • 5620 Posts
  • 2667 Reply Likes
Okay, unfortunately simply waiting for things to settle wasn't working. But it does seem to have corrected the issue by adjusting the transparency setting.

This conversation is no longer open for comments or replies.