Why so slow to launch the cross hairs after "Print Screen" is pressed?

  • 2
  • Question
  • Updated 3 years ago
Hi - I just had my computer updated from XP to Windows 7. When I press the "Print Screen" button to capture an image, it takes roughly 10 seconds for the cross hairs to appear. It was instantaneous in XP. The Delay Capture feature is not enabled.
Photo of Dan

Dan

  • 2 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 2
Photo of GregB

GregB

  • 161 Posts
  • 7 Reply Likes
That's interesting.  It's not just Win7.  I use that and the cross hairs come up immediately.  
Photo of Adam Marks

Adam Marks, Software Developer

  • 124 Posts
  • 13 Reply Likes
Hello Dan,

Does it always take 10 seconds for the crosshairs to appear or is it just the very first capture that it takes 10 seconds to appear?

One thing you could try is to disable the system tray icon :
http://screencast.com/t/5tK3IngdW

Another thing you could try toggling is the "Hide Snagit before Capturing".

Both adding the system tray icon and hiding Snagit take time while launching the crosshairs and it would be interesting to know if one or both of them speed up your crosshair launch time significantly.  

Thanks,
Adam Marks
Developer, TechSmith

Photo of Dan

Dan

  • 2 Posts
  • 0 Reply Likes
Something I did with the tray icon settings has worked. It is almost as if the original settings has the editor stay open but the program close each time I "x"d out of the editor. Now it looks like the Snagit program remains running in the background and there is no lag when i press "print screen". Thanks for all the help.
Photo of randy.s.johnson6060

randy.s.johnson6060

  • 3 Posts
  • 0 Reply Likes
I have the same issue, somewhere between 4-10 seconds with Win7, but I had it on my last windows 7 and had no issues.  This is a super fast 8 core 2.6Ghz PC with 32 Gig of RAM.  So that should not be the issue.  It is SUPER annoying to wait every time I hit "print screen" and then wait for cross hairs.
Photo of randy.s.johnson6060

randy.s.johnson6060

  • 3 Posts
  • 0 Reply Likes
Note, I can have it open, literally click the "capture image" button and it takes that long.  So it has nothing to do with it not open first or something weird.  I do not have the time delay on.
Photo of Adam Marks

Adam Marks, Software Developer

  • 124 Posts
  • 13 Reply Likes
Hello Randy,

Have you tried changing the settings I mentioned above?  Also, how many monitors do you have?  We have seen some problems with a significant capture startup delay with more than 2 monitors,  typically with 4 or 8 monitors attached.

Otherwise, I would recommend creating a support case with us at support.techsmith.com  and we can run some logs that can help see what else might be happening to cause this long of a delay on such a capable machine.

Thanks,
Adam Marks
Developer, TechSmith

Photo of randy.s.johnson6060

randy.s.johnson6060

  • 3 Posts
  • 0 Reply Likes
I did turning off the system tray and the hide features.  They did not impact the wait.  I am running two external monitors off a laptop docking station with the laptop closed.  This is with a pretty powerfull Dell laptop used for 3D modeling.  This is a work computer, so I'm not sure what access I can allow for logs.  I do appreciate the quick feedback.  That is impressive.
Photo of bagee18

bagee18

  • 1 Post
  • 0 Reply Likes
I have a surface pro 2 that has a 2 to 5 second delay after clicking 'print screen' before the cross hairs come up. I deleted 700+ SS's from my library with no change in performance.

Any thoughts?
Photo of Seth Miller

Seth Miller

  • 3 Posts
  • 0 Reply Likes
I am having the exact same problem on a brand new Windows 8.1 system.  Cannot seem to get the delayed capture turned off no matter what I do.  Very frustrating. was there actually a solution to this?
Photo of Stiv Ostenberg

Stiv Ostenberg

  • 1 Post
  • 0 Reply Likes

Confirm problem on my system,  with 4 monitors running on Win 7.


Photo of GregB

GregB

  • 161 Posts
  • 7 Reply Likes
I initially replied 2 years ago that mine came up immediately, but for quite some time now, mine was taking a while to display (I thought it was a Chrome issue), but I will say now I do NOT have any delay.  I got a new laptop a few weeks ago.  I don't know if that has anything to do with it or not.  My Snag It version is 11.4.3
(Edited)
Photo of GregB

GregB

  • 161 Posts
  • 7 Reply Likes
I also just checked my older laptop (for a looong time now the cross hairs have been slow coming up), and now there is no (or very little) delay in the cross hairs showing up.  I'm wondering if it wasn't due to a Chrome upgrade...
Photo of Scott Bailey

Scott Bailey

  • 1 Post
  • 1 Reply Like
Photo of surejcherian

surejcherian

  • 1 Post
  • 0 Reply Likes
Thanks, that worked like a charm!