Win 10 Snagit 19 install error

  • 1
  • Problem
  • Updated 7 months ago

On Win 10, trying to install snagit 19 gives "Snagit 2019 cannot run on Windows 7 RTM with .NET 4.52 installed. Install Windows 7  SPI to run in a supported environment."

Snagit 18 works fine.

Photo of jontwmatt

jontwmatt

  • 2 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of george

george

  • 102 Posts
  • 21 Reply Likes

I'm afraid you have no alternative here.  RTM (Release To Manufacture) does have limitations.  SnagIt 18 may well have worked, but would not pass current Microsoft Security Standards.
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes
You should be on SP1 as a minimum anyway because it patches many security vulnerabilities.  There is in effect, and SP2 too, although it's labelled SP! Convenience Rollup

https://www.lifewire.com/latest-windows-service-packs-updates-2624595
Photo of davidlambert

davidlambert

  • 184 Posts
  • 52 Reply Likes
Why is it giving the error about Win 7 when he is installing on Win 10? Am I missing something here? Did I misread the original post?
(Edited)
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes
Ha Ha.  Good point!  Doh!
Photo of jontwmatt

jontwmatt

  • 2 Posts
  • 0 Reply Likes
Nate G. of Support gave me the fix:
Option 4: Silent Install in Snagit (Windows): Troubleshoot Install Errors