Windows 10 - Display Drivers Stopped Responding

  • 1
  • Problem
  • Updated 2 years ago
Hello,

Although I don't think this is a Camtasia issue, it's occurring when I'm running Camtasia so I figured I post it here in the community to see if anyone else has or had the same issue and solicit any resolution steps or suggestions.

Bit of background, my windows 7 laptop (Lenovo W541, 24 GB ram, lots of HD space, 64-bit) was just wiped clean and setup with Windows 10. Until the upgrade to ten, I ran Camtasia (latest versions) for years without this problem. I also have two addition monitors and my setup looks like this:


The issue. . . When I'm working in Camtasia and I'm playing the video, my display seems to stop and I get this notification.


It generally goes away after a few seconds but it defiantly disrupts my workflow and is a general pain in the butt.

What do you guys think?

THANKS!

ed
Photo of Eddiebo

Eddiebo

  • 73 Posts
  • 15 Reply Likes
  • like I could use a hand. :-)

Posted 3 years ago

  • 1
Photo of lisa.goldring

lisa.goldring

  • 2 Posts
  • 0 Reply Likes

I have the exact same issue, same laptop, same setup, though I only run 2 monitors. Any suggestions would be greatly appreciated!

Photo of Eddiebo

Eddiebo

  • 73 Posts
  • 15 Reply Likes
Hey Lisa,

Eventually mine just fixed itself.  I don't remember doing anything special.  Wish I could help more.
Photo of lisa.goldring

lisa.goldring

  • 2 Posts
  • 0 Reply Likes
i ended up reinstalling my display drivers, and I haven't had the issue since then. I hope this helps.