Won't Record System Audio - No Error Messasge

  • 1
  • Problem
  • Updated 5 years ago
With Camtasia 7 and Windows 7, I cannot record system audio. I am NOT getting any error messages, nor do I have the red circle icon over the blank bars. It simply will not record system audio, even though I have that option checked. Narration is fine, but that's all I get. I use an ASIO interface (Focusrite Scarlett 2i2). What can I do? It HAS worked in the past. But no longer.

Thanks.

Ken
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 9173 Posts
  • 4825 Reply Likes

Regards, Joe

Click on Image to enlarge and see clearly.
(Edited)
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
Thanks Joe. I did have everything se up that way. No go. I am recording Reaper tutorials - how to record and edit audio, ironically. I think it may have something to do with the program. I'll ask on the Reaper. Forum.

Ken
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Did you ever find a solution for this, Ken?
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
I actually didn't, Logan. But interestingly, it works just fine when I'm using Audacity to record my audio. It just doesn't seem to work when using Reaper. I'll circle back and ask again on the Reaper forum.

Thanks for checking in!

Ken
Photo of Faron Bracy

Faron Bracy, Software Engineer

  • 26 Posts
  • 0 Reply Likes
Are you using the asio4all drivers in Reaper? It might have something to do with that. You could temporarily disable them and see if that changes anything. I also found a couple threads here that have more about ASIO if that turns out to be the problem.

https://feedback.techsmith.com/techsmith/topics/asio_alternative 
https://feedback.techsmith.com/techsmith/topics/support_for_asio_audio_drivers

Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
Actually no. I'm using the Driver that came with the interface - a Focusrite Scarlett 2i2.

Thanks for the links. I'll check those out.

Cheers!

Ken
Photo of Rick Stone

Rick Stone

  • 6646 Posts
  • 3206 Reply Likes
Hi there

In case you don't find a decent workaround, you did mention "it works just fine when I'm using Audacity to record my audio. It just doesn't seem to work when using Reaper.". Now I'm not sure if that means Camtasia records Audacity just fine or if it instead means Audacity can record it just fine.

In case it's the latter, perhaps your workaround is to use Audacity to capture the audio and Camtasia to capture the video. Then add the audio to the Camtasia recording and match things up.

Cheers... Rick :)
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
Thanks Rick. The problem is that part of the course is to show how to record in Reaper, and then be able to have the screen capture play back what was recorded in Reaper. My workaround to date has been to import the little bits of audio and then insert them after-the-fact. But that's tedious. 

Thanks though.

Ken
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Ken is there another option in Reaper to not use ASIO and use a Windows Driver or something? I don't use Reaper but I use Adobe Audition CC sometimes and it works for me but I do not use the Focusrite either. I just use a Mackie Mixer Board and 2 USB Sound cards and run everything into my mixer channels and also for a backup audio I use a Digital Roland R-05 Recorder. I know when I had my Focusrite I had to use something other than ASIO or ASIO4All to make it work. Sorry this might not be much help but might give you some direction in trying different things and settings. Let us know. Have a great day and thanks for posting.
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
Thanks Fred. I'll be able to get back to recording again later this week and I'll try all these things again and report back.

Cheers!

Ken
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Your welcome Ken. Look forward to hearing back on what you find out. Have a great day.
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
This was a long time ago, but I have no solution. I can't figure out why Camtasia Studio 7 will not record system audio when I'm using Reaper. The workarounds suggested would defeat my purpose, which is to teach folks how to use Reaper. The sound card setup must be what it would be for folks NOT trying to also record tutorials with Camtasia:-P. Sigh. Did this maybe get fixed in the newest version of Camtasia Studio?
Photo of Rick Stone

Rick Stone

  • 6646 Posts
  • 3206 Reply Likes
The only way to know for certain is to download the evaluation version, install and test!

Should take you less than 30 minutes to try. ;)
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Ken I would have to agree with Rick to see if the newest version might work. If not, then I would suggest contacting TechSmith Support and see if they have an idea of why it is not working. I know Camtasia Studio still does not support ASIO Drivers or the ASIO Functions. So if that is what you are looking for then it is answered but you may still want to contact TechSmith and ask them to make this a feature request (Idea), as I have also wanted this implemented for quite awhile for using Professional Audio Equipment and Software. I do not use Reaper so I cannot answer those questions on that software. The contact information once again is below for you to use Ken.

TechSmith Support Information

http://support.techsmith.com/


Phone: +1.517.381.2300
Toll Free: 800.517.3001
(U.S. & Canada Only)
8:00 AM to 7:00 PM EST Monday through Friday

I hope this helps and thanks for posting. Have a nice day/night and let us know what you find out if you contact TechSmith. Thanks.
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
Thanks. Yes, this does help. I will try downloading the trial version of the latest version. But I am (have to) using ASIO drivers. So I'll do as you say.

Cheers!

Ken
Photo of Ken Theriot

Ken Theriot

  • 31 Posts
  • 5 Reply Likes
I just added my voice to the cry for adding ASIO support in the Ideas area. I also downloaded the trial version of Camtasia Studio 8. Not only did it not solve the "not-recording-system-audio" problem, it recorded only the left channel (playback only came out of the left speaker) of my microphone! When I tried to go into Options/Audio Settings via the Record Screen function, it ("Audio Settings") was grayed out. Sigh. HOWEVER, here's the good news! First, I went back to version 7. I actually don't need ASIO for at least some of the recording in Reaper. I was able to change the driver to "WASAPI" and still choose my Focusrite interface as the device. At first this didn't solve the System Audio" thing. But then I noticed another option in Reaper's Audio Device screen that said "Audio Thread Priority." I changed that from its default "ASIO Default/ MMCSS Pro Audio / Time Critical" setting to the "Normal" setting. And BINGO! Camtasia Studio now records system audio!!!! Woohoo!!! And I didn't even have to upgrade to version 8. Now it remains to be seen whether not using the ASIO driver causes problems when recording with virtual instruments and MIDI, or other time-sensitive multi-track applications.

Thanks for all your help!

Ken
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Glad to hear that you could find something that worked Ken and thanks for posting back your reults. I am hoping they still add ASIO in the next version myself. Keep me updated on new things you try to let us know if it works or not. Have a great day/night.

This conversation is no longer open for comments or replies.