Wrong aspect ratio on Library assets added to new projects

  • 1
  • Problem
  • Updated 3 weeks ago
  • (Edited)
I do all of my work in Camtasia 9 with the canvas size set to 1920 x 1080. I've created a bunch of library assets that I've used in my videos, all with that aspect ratio. Today, I created a new project with that canvas size, added some of these assets, and their aspect ratio is more like 4:3, too narrow and too tall for the canvas. Adjusting their size in the Viewport doesn't work, as it maintains this screwy aspect ratio.

I tried saving these assets from an existing video to the Library again, but when I add them to a new project I get the same result, so the problem is apparently with new projects (I tried multiple new projects). However, if I record the screen, the aspect ratio of the resulting media is correct!

There must be some simple explanation for this - such as a setting someplace - but I'm stumped! Do any of you know what causes this?

Photo of bnystrom

bnystrom

  • 186 Posts
  • 87 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Dubie

Dubie

  • 961 Posts
  • 740 Reply Likes
There is no setting I am aware  of that would change the aspect rations like that.

Of course the first step in to completely close and reopen Camtasia.

It may have just had a burp when it loaded.

Second I would do is to backup my library (just in case you know) and do a repair install.
A file may have became corrupt.

Other than that.

Contact support. It should not be doing that.

:)
Photo of bnystrom

bnystrom

  • 186 Posts
  • 87 Reply Likes
I've restarted Camtasia numerous times and it doesn't make any difference.

Another bizarre discovery is that if I add one of these Library assets to an existing video, they work fine.

This only happens when I create new videos.

For now, the workaround is to start with an existing and delete the content I don't need, but that's not something I want to do indefinitely.
Photo of Joe Morgan

Joe Morgan

  • 5631 Posts
  • 2923 Reply Likes
In the past, like with Camtasia 8.
If you created a fullscreen callout, made it transparent.Then grouped it with library assets.That ensured the asset would retain it's exact location, size,aspect ratio,etc.

It's only more recently that users have reported Camtasia retaining these settings, without attaching a callout. I can't tell you if it's a bug or not.
I just know creating callout "May" be the best practice.

Regards,Joe
Photo of kayakman

kayakman, Champion

  • 6243 Posts
  • 1828 Reply Likes
I just did a quick test in CS9; made a library asset, from a callout, that filled the 1920x1080 canvas at 16:9 aspect; in new project, the asset went on timeline at correct aspect; resizing retained the aspect

what type are the assets that are giving you problems? 

perhaps contact free tech support; maybe they can offer insight
Photo of bnystrom

bnystrom

  • 186 Posts
  • 87 Reply Likes
The two main assets in question are the intro and outro that I used regularly. They contain static images, dynamic images, animations, callouts and audio. I grouped them and saved them to the library. I haven't produced them and saved the .mp4 files, as I sometimes need to make minor edits.

I agree that contacting Tech Support is probably my best bet, as this was not a problem in the past and I suspect it's probably due a to a change in a maintenance release or some other issue with CS9. It could be that there's a setting somewhere that's changed and needs to be changed back, but I haven't been able to find anything.

BTW, these items are being resized to 852 x 480 when they're added to the timeline. 

UPDATE:
Another odd tidbit is that if I play these items by double-clicking on them in the Library, they look fine.

I just did some additional testing and found out what it's doing, but not why. The background image is a different aspect ratio than the view port and when I import one of these items, it sizes itself to fit the height of the view port, rather than the width. If I manually resize and reposition them, they'll work. That doesn't explain why they work fine without all of this nonsense when imported into and existing video.
(Edited)