Change zoom behavior function on numerical keypad

  • 3
  • Idea
  • Updated 8 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposing

I wrote a tweet about a problem with the numeric keypad with Snagit. The response from TechSmith was to go here and explain. When using Snagit 9 and 10 and using the numerical keypad for entering numbers, the keypad has been programmed for when you use the minus or plus keys cause a zoom function. This is a problem when you are use to using the numerical keypad. Also if you use the division sign on that keypad nothing will enter. That eliminates entering dates. I don't know of any other SW that operates this way. Why not use the Control, or Alt key with the minus or plus for the zoom function. There is already a zoom at the bottom right-hand corner of the screen. We have 75 licenses and half the user don't like the zoom on the numeric keypad.
Photo of Ron

Ron

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 8 years ago

  • 3
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Thanks Ron. I see exactly what you mean. People doing precision work enjoy the ability to quickly zoom in and get back out, so I can see good reasoning to have a key assignment. However, you do expose a weakness if people are heavy users of the Num Pad.

The team will see this too. There's probably a good discussion to be had here. I have also seen examples, where you leverage the scroll wheel of the mouse, often in conjunction with the Ctrl key, etc.

Thanks again for posting!
Mike Curtis
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Do your users know that if they hold Shift + [plus] or [minus] or [/] on the Num pad it gives the character? It sounds like it's the opposite of the behavior you were expecting, but I wonder what they think.
Photo of Ron

Ron

  • 2 Posts
  • 0 Reply Likes
Hi Mike,
If you can take a look at other applications. I don't think you will find any that have the numeric keypad behave this way. My exposure to graphics applications is AutoCad, SolidWorks, Adobe Illustrator, Corel Draw and Xara and non of these operate that way. Can you provide me with the names of other popular applications that operate this way. I am at a loss for knowing any others. Please let me know if something can be done? Maybe have the user select if they want that option.

Thanks,
Ron
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Hi Ron,

Our interaction designers and the team is aware of your feedback. I'd like to change this to a feature request (idea) as it's working as designed. I'm not saying whether it's right or wrong, but it's something we'll want to look into carefully.

For example, when doing precision editing of screenshots for documentation (e.g. you are trying to fill a small area with transparency or manipulate a 1 pixel border) it is really convenient to be able to zoom in and out as quickly as possible--ideally without moving your cursor.

However you make good points and there are options like holding Shift, perhaps using the scroll wheel, etc.

I think right now, the option for your colleagues would be to either hold Shift if they want the +, - , / or to use the other number keys. I'm not aware of any hack or setting that can change the default behavior.

Thanks for kicking off a good discussion!
Mike Curtis
Photo of harringg

harringg

  • 3 Posts
  • 0 Reply Likes
Is there a setting to disable the plus and minus keys on the 10-key pad from zooming in and out SnagIt 10 Editor?

Or at the very least, a way to have it not zoom when a text box is being edited?

Draw>Drawing Tools>Text

If I want to type a phone number over a screen grab, I'd type: 555-555-5555

But when I use the 10-key pad, I type 555- and the screen grab shrinks to 50% as soon as I enter the minus key stroke and the only text in the box is 555 and I have to zoom out and continue using the symbols above the P and the [

It's habit to type numbers using a 10-key pad.

I see the logic of using keyboard shortcuts, but they should be disabled when in a text box.

This reply was created from a merged topic originally titled
Option to disable keyboard shortcut for zoom.
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Harringg, thanks for the examples and ideas. You have some good points!
Photo of Kent Liner

Kent Liner

  • 1 Post
  • 0 Reply Likes
When typing in a number we sometime use hyphens. And when doing so the screen changes to a smaller size. You have to start over. My solution to this is use shift key and hyphen. Sometimes I forget to do so. Do you have a fix for this?

Thanks,
Kent Liner
Madix Inc.

This reply was created from a merged topic originally titled
Hyphen button changes image size.

This conversation is no longer open for comments or replies.